STP配置

发布于 2019-10-18  409 次阅读


拓扑图

第一步:#分别配置pc的ip地址,以及给每个交换机创建vlan10,vlan20,vlan30,vlan40

     # PC11 

      ip address 192.168.10.1  255.255.255.0 

        gateway 192.168.10.254 

    #pc12

      ip address 192.168.20.1 255.255.255.0

       gateway 192.168.20.254

    #pc13 

      ip address 192.168.30.1 255.255.255.0

        gateway 192.168.30.254

    #pc14

   ip address 192.168.40.1 255.255.255.0

      gateway 192.168.40.254

  #pc17 

   ip address 192.168.10.2 255.255.255.0

    gateway 192.168.10.254

  #pc16

    ip address 192.168.20.2 255.255.255.0

    gateway 192.168.20.254

   #pc15

  ip address 192.168.30.2 255.255.255.0

   gateway 192.168.30.254

 #pc 18

 ip address 192.168.40.2 255.255.255.0

  gateway 192.168.40.254

# 分别给所有交换机创建vlan,保持vlan数据库保持一致

#假如左上角的是sw1,右上角sw2,最下面是sw3

# 在全局配置模式下:

    #vlan 10  , 20 ,30 ,40 

#配置各个交换机上的端口链接是trunk

# 配置sw3

 # interface range f0/1-2

 switchport mode trunk  //思科二层交换机不用封装dot1q,直接trunk

#配置sw2

#interface range f0/1-2

switchport trunk encapsulation dot1q //思科三层交换机必须封装dot1q,才能设置trunk链路

switchport mode trunk 

#配置sw1

#interface range f0/1-2 

switchport trunck  encapsulation dot1q //思科三层交换机必须封装dot1q协议,才能设置trunk链路

switchport mode trunk

#以上配置完之后,先确定根交换机,副根交换机,和接入层交换机,

 #我确定完之后,sw1为主根交换机,sw2为副根交换机,sw3为接入层交换机

# 配置,在sw1中,配置vlan10,vlan20,为主根,vlan30,vlan40,为次根

 # 在全局配置模式下:spanning-tree vlan 10 priority  0 

                                   spanning-tree-vlan 20 priority 0

                                   spanning-tree-vlan 30 priority 4096

                                   spanning-tree-vlan 40 priority 4096   // #配置生成树的主根时,设置它的优先级,优先级默认是32768,比它小就越靠谱,#优先级默认是4096的倍数

# 配置,在sw2中,配置vlan30,vlan40,为主根,vlan10,vlan20,为次根

 # 在全局配置模式下:spanning-tree vlan 10 priority  4096 

                                   spanning-tree-vlan 20 priority 4096

                                   spanning-tree-vlan 30 priority 0

                                   spanning-tree-vlan 40 priority  0  // #配置生成树的主根时,设置它的优先级,优先级默认是32768,比它小就越靠谱,#优先级默认是4096的倍数

#接下来打开端口f0/2

intface f0/2

no shutdown 

#现在用命令ping 10.1.1.2 测试 看是否可以ping通,如果ping通的话,就说明生成树配置成功,

#从上图可以看书,是可以ping通的,说明没有出现环路,起到了负载均衡的作用,流量即可以走左边,又可以走右边,

#要想到各个vlan 之间可以互通的话,就必须配置虚拟网关

#配置 sw1 交换机,vlan10.vlan20,vlan30,vlan40,的虚拟网关,思科三层交换机路由功能默认是关闭的,需要开启 :ip routing 

# interface vlan 10

  ip address 192.168.10.254 255.255.255.0

          no shutdown 

             exit

interface vlan 20

ip address 192.168.20.254 255.255.255.0

no shutdown

exit

interface vlan 30

ip address 192.168.30.254 255.255.255.0

no shutdown 

exit

interface vlan 40

ip address 192.168.40.254 255.255.255.0

no shutdown 

#接下来用vlan10 网段的pc  ping vlan 30,40之间的pc 如下图

#接下来我关闭sw3 f0/1 .使他流量从副根上走,起到备份作用,如下图

#继续ping vlan 30 ,vlan 40 如下图

#以上说明测试成功,说明起到备份作用

#同理可得,右边线路坏了的话,会从左边走

总结:配置生成树,目的是为了防止物理环路的产生,防止广播风暴,好处是,可以起到负载均衡的作用,和链路的冗余备份


备战CCIE